<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]> <html class="no-js" lang="en"> <![endif]-->
<html dir="ltr" lang="en-us" itemscope itemtype=&quot;http://schema.org/Article&quot;>
<head>
	<!-- <PageMap>
	<DataObject type="publication">
		<Attribute name="author">Staff</Attribute>
		<Attribute name="date">2019-01-27T00:00:00-05:00</Attribute>
		<Attribute name="category">Death Notices</Attribute>
	</DataObject>
</PageMap> -->
	<meta name="m:title" content="rogers-william-a" /><meta name="bn:page_type" content="post" /><meta name="bn:post_template" content="single-obits.php" /><meta name="bn:post_category" content="death-notices" /><meta name="bn:post_id" content="2553364" /><meta name="bn:post_title" content="ROGERS, William A." /><meta name="bn:post_name" content="rogers-william-a" /><meta name="bn:post_date" content="2019-01-27T00:00:00-0500" /><meta name="bn:post_modified" content="2019-01-29T17:54:32-0500" /><meta name="bn:post_type" content="post" />		<script src="https://data.bntech.io/m/ma5cd450e954ac0/ads/ads.js"></script>
		<script src="https://data.bntech.io/m/3/js/1y9WbPk5fHPLhStc2nrD10OT8kK7KWn0?m=m5cd450e954a16&a=ma5cd450e954ac0"></script>
		<script>m5cd450e954a16.track('view');</script>
		<script src='https://gapi.bntech.io/js/1y9WbPk5fHPLhStc2nrD10OT8kK7KWn0/bnsso'></script>
	
	<!-- <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> -->
	<meta charset="UTF-8" />

	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta name="msvalidate.01" content="6A71746E6255F4DF96D0FB31B86ED344" />
	<meta name="msvalidate.01" content="1C1A9A9E4393D229287AA7FCE55A374C" />
	<meta http-equiv="Cache-control" content="No-cache">
	<meta http-equiv="Content-Security-Policy" content="default-src *; style-src * 'unsafe-inline'; script-src * 'unsafe-inline' 'unsafe-eval'; img-src * data: 'unsafe-inline'; connect-src * 'unsafe-inline'; frame-src *;">
	<meta name="theme-color" content="#000000" />
	<meta name="robots" content="noarchive">

	<!-- show thumbnail meta if the story has a image -->	<meta name="description" content="ROGERS - William A. January 15, 2019. Survived by loving family and friends. A Funeral Service will be held on Wednesday, February 6, 2019, at 11:30 AM at THE D…" />

			<link rel="shortcut icon" type="image/x-icon" href="https://buffalonews.com/wp-content/themes/tbn-2016/images/favicon.ico?">
	<script id="ns_script_dc" data-key="594b9819-366f-4c1d-956b-cd029ef86683" data-e="5" src="//cdn.includemodal.com/sp.js" type="text/javascript"></script><title>ROGERS, William A. &#8211; The Buffalo News</title>
<link rel='dns-prefetch' href='//cdn.polyfill.io' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<meta property="fb:pages" content="181362508150" />
<meta property="fb:pages" content="84423347939" />
<meta property="fb:pages" content="681822355240281" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="ROGERS - William A. January 15, 2019. Survived by loving family and friends. A Funeral Service will be held on Wednesday, February 6, 201..." />
<meta name="twitter:title" content="ROGERS, William A." />
<meta name="twitter:site" content="@TheBuffaloNews" />
<meta name="twitter:image" content="https://bnwordpress.s3.amazonaws.com/placeholder/the-buffalo-news-fallback.jpg" />
<link rel="publisher" href="https://plus.google.com/+buffalonews"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="ROGERS, William A." />
<meta property="og:description" content="ROGERS - William A. January 15, 2019. Survived by loving family and friends. A Funeral Service will be held on Wednesday, February 6, 201..." />
<meta property="og:url" content="https://buffalonews.com/2019/01/27/rogers-william-a/" />
<meta property="og:site_name" content="The Buffalo News" />
<meta property="article:publisher" content="https://www.facebook.com/TheBuffaloNews" />
<meta property="article:section" content="Death Notices" />
<meta property="article:published_time" content="2019-01-27T00:00:00-04:00" />
<meta property="article:modified_time" content="2019-01-29T12:54:32-04:00" />
<meta property="og:updated_time" content="2019-01-29T12:54:32-04:00" />
<meta property="og:image" content="https://bnwordpress.s3.amazonaws.com/placeholder/the-buffalo-news-fallback.jpg" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/buffalonews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='obits-style-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/css/obits.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='load-raleway-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700&#038;ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/css/bootstrap.min.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-millerheadline-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/fonts/MillerHeadline-Bold.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/style.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/css/font-awesome.min.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='customGoogleFont-css'  href='https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%2C700i&#038;ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://buffalonews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='dfp-css-css'  href='https://buffalonews.com/wp-content/plugins/content-management/css/widget-dfp-ad/style.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wunderbar-widget-style-css'  href='https://buffalonews.com/wp-content/plugins/content-management/css/widget-wunderground/wunderbar.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-widget-style-css'  href='https://buffalonews.com/wp-content/plugins/content-management/css/widget-wunderground/widget.css?ver=5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://buffalonews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bootstrap.min.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/main.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/plugins/content-management/js/widget-dfp-ad/script.js?ver=5.1'></script>
<link rel='https://api.w.org/' href='https://buffalonews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://buffalonews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://buffalonews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Orchard Park, EA top ECIC swimming' href='https://buffalonews.com/2019/01/26/orchard-park-ea-top-ecic-swimming/' />
<link rel='next' title='ECC to offer free dental services for Give Kids a Smile Day' href='https://buffalonews.com/2019/01/27/ecc-to-offer-free-dental-screens-for-give-kids-a-smile-day/' />
<meta name="generator" content="WordPress 5.1" />
<link rel="canonical" href="https://buffalonews.com/2019/01/27/rogers-william-a/" />
<link rel='shortlink' href='https://buffalonews.com/?p=2553364' />
<link rel="alternate" type="application/json+oembed" href="https://buffalonews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbuffalonews.com%2F2019%2F01%2F27%2Frogers-william-a%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://buffalonews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbuffalonews.com%2F2019%2F01%2F27%2Frogers-william-a%2F&#038;format=xml" />
<link rel="icon" href="https://s3.amazonaws.com/bncore/wp-content/uploads/2016/11/buffnewslogo-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s3.amazonaws.com/bncore/wp-content/uploads/2016/11/buffnewslogo-500x500.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s3.amazonaws.com/bncore/wp-content/uploads/2016/11/buffnewslogo-500x500.png" />
<meta name="msapplication-TileImage" content="https://s3.amazonaws.com/bncore/wp-content/uploads/2016/11/buffnewslogo-500x500.png" />

			<!-- START Parse.ly Include: Standard -->
		<div id="parsely-root" style="display: none;">
			<span id="parsely-cfg" data-parsely-site="buffalonews.com"></span>
		</div>
		<script>
			(function(s, p, d) {
				var h = d.location.protocol,
					i = p + "-" + s,
					e = d.getElementById(i),
					r = d.getElementById(p + "-root"),
					u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net" :
					"static." + p + ".com";
				if (e) return;
				e = d.createElement(s);
				e.id = i;
				e.async = true;
				e.src = h + "//" + u + "/p.js";
				r.appendChild(e);
			})("script", "parsely", document);

			(function(w) {
				w.PARSELY = {
					autotrack: false,
					onReady: function() {
						document.addEventListener('DOMContentLoaded', () => {
							PARSELY.updateDefaults({
								data: {
									logged_in: (BNTech.SSO.isLoggedIn === 1 ? 'true' : 'false')
								}
							});
							PARSELY.beacon.trackPageView();
						});
					}
				}
			})(window);
		</script>
		<!-- END Parse.ly Include: Standard -->

	
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
</script>

<!-- Configure DFP ad slots -->
<script type='text/javascript'>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</script>
<!-- Google Tag Manager Data Layer -->
<script type="text/javascript">
	/* Start Hide/Show search box */
	jQuery(document).ready(function (jQuery) {
		// URL toolbox - helps grabbing elements in the URL
		var _d = document;
		var _dl = _d.location;
		var _dlp = _dl.pathname;
		var _dls = _dl.search;
		var _dr = _d.referrer;

		function  get_paywall_Count() {
			count ='';
			return count;
		}

		// Initialize your data layer and start pushing variables from custom WordPress PHP data layer
		//var dataLayer;
		if (typeof dataLayer !== "undefined") {
			//code
			dataLayer.push({
				// handles Custom Parameters.
				'GTM_donottrack': BNTech.AdBlock.doNotTrack,
				'GTM_loggedin' : BNTech.SSO.isLoggedIn === 1 ? true : false,
				'GTM_adBlockOn': BNTech.AdBlock.enabled,

				
				'GTM_WP_authorname': 'Staff',
				'GTM_WP_post_type': 'post',
				'GTM_WP_Number_Comments': '0',
				'GTM_WP_Page_Title': 'ROGERS, William A.',
				'GTM_WP_Tags': '',
				'GTM_paywall_Pages_Remaining': get_paywall_Count(),
				'GTM_WP_Category': 'Death Notices',
			});
		}
	});
</script>
	<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": {
				"@type": "WebPage",
				"@id": ""
			},
			"headline": "",
			"image": {
				"@type": "ImageObject",
				"url": "",
				"height": 800,
				"width": 800
			},
			"datePublished": "2019-01-27T00:00:00Z",
			"dateModified": "2019-01-29T12:54:32Z",
			"author": {
				"@type": "Person",
				"name": ["Staff"]
			},
			"publisher": {
				"@type": "Organization",
				"name": "The Buffalo News",
				"logo": {
					"@type": "ImageObject",
					"url": "https://bncore.s3.amazonaws.com/wp-content/themes/tbn-2016/images/bn_logo_35.jpg",
					"width": 35,
					"height": 35
				}
			},
			"url": "",
			"dateCreated": "2019-01-27T00:00:00Z",
			"articleSection": "Death Notices",
			"creator": ["Staff"],
			"keywords": ["Death Notices"]
		}
	</script>

<!-- Google Search Results Site Search and Contact Card -->
<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"name": "The Buffalo News",
		"description": "The Buffalo News is Western New York&#039;s No. 1 news source, providing in-depth, up to the minute news. The Buffalo News brings you breaking news and the latest in local news, sports, business, politics, opinion and entertainment from around Buffalo and Western New York.",
		"alternateName": "Buffalo News",
		"url": "https://www.buffalonews.com/",
		"potentialAction": {
			"@type": "SearchAction",
			"target": "https://www.buffalonews.com?s={search_term_string}",
			"query-input": "required name=search_term_string"
		}
	}
</script>

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "Organization",
		"url": "https://www.buffalonews.com/",
		"logo": "http://pbs.twimg.com/profile_images/2553395093/xvx84nnqjk9bokm82d8p.png",
		"contactPoint": [
			{
				"@type": "ContactPoint",
				"telephone": "+1-800-777-8640",
				"contactType": "customer service",
				"contactOption": "TollFree"
			}, 
			{
				"@type": "ContactPoint",
				"telephone": "+1-716-842-1111",
				"contactType": "customer service"
			}
		],
		"sameAs": [
			"https://www.facebook.com/TheBuffaloNews",
			"https://twitter.com/TheBuffaloNews",
			"https://plus.google.com/+buffalonews",
			"https://en.wikipedia.org/wiki/The_Buffalo_News"
		]
	}
</script>

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "LocalBusiness",
		"address": {
			"@type": "PostalAddress",
			"addressLocality": "Buffalo, NY",
			"addressRegion": "NY",
			"streetAddress": "1 News Plaza",
			"postalCode": "14203"
		},
		"logo": {
			"@type": "ImageObject",
			"url": "https://bncore.s3.amazonaws.com/wp-content/themes/tbn-2016/images/bn_logo_35.jpg",
			"width": 35,
			"height": 35
		},
		"description": "The Buffalo News is Western New York&#039;s No. 1 news source, providing in-depth, up to the minute news. The Buffalo News brings you breaking news and the latest in local news, sports, business, politics, opinion and entertainment from around Buffalo and Western New York.",
		"name": "The Buffalo News",
		"telephone": "+1-800-777-8640"
	}
</script>


<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "Place",
		"address": {
			"@type": "PostalAddress",
			"addressLocality": "Buffalo, NY",
			"addressRegion": "NY",
			"streetAddress": "1 News Plaza",
			"postalCode": "14203"
		},
		"geo": {
			"@type": "GeoCoordinates",
			"latitude": "42.8942568",
			"longitude": "-78.8839152"
		},
		"name": "The Buffalo News"
	}
</script>

	<script>
		(function(i, s, o, g, r, a, m) {
			i['GoogleAnalyticsObject'] = r;
			i[r] = i[r] || function() {
				(i[r].q = i[r].q || []).push(arguments)
			}, i[r].l = 1 * new Date();
			a = s.createElement(o),
				m = s.getElementsByTagName(o)[0];
			a.async = 1;
			a.src = g;
			m.parentNode.insertBefore(a, m)
		})(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

		ga('create', 'UA-5339712-1', 'auto');
		ga('set', 'dimension1', "Staff");

		ga('send', 'event', 'Author', 'Staff', 'Staff',1,{'nonInteraction': 1});

		ga('set', 'dimension6', 'Death Notices');

		ga('send', 'event', 'Category', 'Death Notices', 'Death Notices',1,{'nonInteraction': 1});
		ga('send', 'pageview');
	</script>

	
	
		<script>
		(function() {
			var cx = '006900656957014357757:w0ygloomumk';
			var gcse = document.createElement('script');
			gcse.type = 'text/javascript';
			gcse.async = true;
			gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(gcse, s);
		})();
	</script>

	<!-- Meta, SEO and Social share settings are handled by Wordpress SEO plugin, some plugin actions are in functions -->
	<link rel="apple-touch-icon" href="//www.buffalonews.com/images/bookmark-114.png">
	<meta property="fb:app_id" content="1794775337415471" />

	<!-- Facebook Pixel Code  -->
	<script>
		! function(f, b, e, v, n, t, s) {
			if (f.fbq) return;
			n = f.fbq = function() {
				n.callMethod ?
					n.callMethod.apply(n, arguments) : n.queue.push(arguments)
			};
			if (!f._fbq) f._fbq = n;
			n.push = n;
			n.loaded = !0;
			n.version = '2.0';
			n.queue = [];
			t = b.createElement(e);
			t.async = !0;
			t.src = v;
			s = b.getElementsByTagName(e)[0];
			s.parentNode.insertBefore(t, s)
		}(window,
			document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');
		fbq('init', '1041323275912628');
		fbq('track', 'PageView');
	</script>
	<noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=1041323275912628&ev=PageView&noscript=1" /></noscript>
	<!-- DO NOT MODIFY End Facebook Pixel Code -->

</head>

<body id="site-id-1" class="post-template post-template-single-obits post-template-single-obits-php single single-post postid-2553364 single-format-standard article deaths"data-section="default" data-ip="72.30.14.91"><div id="fb-root"></div>
<script type="text/javascript">
	(function() {
		var ARTICLE_URL = window.location.href;
		var CONTENT_ID = 'everything';
		document.write(
			'<scr'+'ipt '+
			'src="//survey.g.doubleclick.net/survey?site=_hlh5tund53ozsyfccrjkwy6zsy'+
			'&amp;url='+encodeURIComponent(ARTICLE_URL)+
			(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
			'&amp;random='+(new Date).getTime()+
			'" type="text/javascript">'+'\x3C/scr'+'ipt>'
		);
	})();
</script>

<script>
function receiveAdMessages(e) {
	if (e.origin == location.protocol+'//tpc.googlesyndication.com' || e.origin == location.protocol+'//buffalonews.com') {
		var details = e.data + '';
		var action = details.split(':')[0];
		if(action == 'sizing') {
			jQuery(details.split(':')[1]).animate({'height': details.split(':')[2]}, 500);
		} else if (action == 'display') {
			jQuery(details.split(':')[1]).css({'display': details.split(':')[2]}, 500).delay( 500 );
		} else if (action == 'close') {
			jQuery("nav#header").addClass('navbar-fixed-top');
			jQuery("#headerSpacer").css('position','');
		}
	}
}
window.addEventListener('message',receiveAdMessages, false);
jQuery(document).ready(function(jQuery) {
	//hide subscribe today button if user is logged in.
	if (BNTech.SSO.isLoggedIn === 1) {
		jQuery("#subscribe-today-button").remove();
	}
});
</script>
<div class="no-print">
	<div id="tophat">
		<script>
			googletag.cmd.push( function() { googletag.display('tophat'); });
		</script>
	</div>
</div>
<nav id="top-nav" style="background-color: #222;">
	<div id="top-nav-left">

		<input type="checkbox" id="menu-input">
		<label for="menu-input">
			<div id="menu-icon"></div>
		</label>

		<div id="menu-dropdown">

			<form id="dropdown-searchform" method="get" name="cse-search-box" role="search" action="/?s">
				<input type="hidden" name="cx" value="006900656957014357757:65jm81-837s">
				<input type="hidden" name="cof" value="FORID:10">
				<input type="hidden" name="ie" value="UTF-8">
				<input type="text" id="dropdown-search-field" name="s" placeholder="Search">
				<input type="submit" value="Search">
			</form>
			<script src="https://www.google.com/coop/cse/brand?form=dropdown-searchform&amp;lang=en&cx=006900656957014357757:65jm81-837s"></script>

			<a href="http://subscribe.buffalonews.com/?utm_source=sub_btn&utm_medium=button&utm_campaign=sub_nav_btn" id="subscribe-today-button" class="btn btn-block subscribe-button ">Subscribe Today</a>

				<a href="/" id="menu-dropdown-home">BuffaloNews.com</a>

			<style>
				.menu-default {
					background-color: #222;
				}
			</style>
			<div class="menu-z-bn-hamburger-menu-container"><ul id="menu-z-bn-hamburger-menu" class="menu"><li id="menu-item-1161142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1161142"><a href="https://buffalonews.com/section/local-news/">Local News</a></li>
<li id="menu-item-1161143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1161143"><a href="https://buffalonews.com/section/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-1161144" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1161144"><a href="https://buffalonews.com/section/sports/bills/">Bills</a></li>
	<li id="menu-item-1163118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163118"><a href="https://buffalonews.com/section/sports/sabres/">Sabres</a></li>
	<li id="menu-item-2434569" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2434569"><a href="https://buffalonews.com/section/sports/high-schools/">High Schools</a></li>
	<li id="menu-item-2437486" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2437486"><a href="https://buffalonews.com/high-schools-scoreboard/">High Schools Scoreboard</a></li>
	<li id="menu-item-1163123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163123"><a href="https://buffalonews.com/section/sports/colleges/">Colleges</a></li>
	<li id="menu-item-1163128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163128"><a href="https://buffalonews.com/section/sports/bisons/">Bisons and Baseball</a></li>
	<li id="menu-item-1163127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163127"><a href="https://buffalonews.com/section/sports/bandits/">Bandits</a></li>
	<li id="menu-item-1163131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163131"><a href="https://buffalonews.com/section/sports/soccer/">Soccer</a></li>
	<li id="menu-item-1163132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163132"><a href="https://buffalonews.com/section/sports/outdoors/">Outdoors</a></li>
	<li id="menu-item-1300268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1300268"><a href="https://buffalonews.com/section/sports/wny-auto-racing/">WNY Auto Racing</a></li>
	<li id="menu-item-1868649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1868649"><a href="https://buffalonews.com/section/sports/colleges/ncaa-hoops/">NCAA Basketball</a></li>
</ul>
</li>
<li id="menu-item-1163122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163122"><a href="https://buffalonews.com/section/sports/bills/">Bills</a>
<ul class="sub-menu">
	<li id="menu-item-2107483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107483"><a href="https://buffalonews.com/section/sports/bills/news/">News</a></li>
	<li id="menu-item-2107466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107466"><a href="https://buffalonews.com/section/sports/bills/analysis/">Analysis</a></li>
	<li id="menu-item-2107468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107468"><a href="https://buffalonews.com/section/sports/bills/commentary/">Commentary</a></li>
	<li id="menu-item-2107469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107469"><a href="https://buffalonews.com/section/sports/bills/fandom/">Fandom</a></li>
	<li id="menu-item-2107473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107473"><a href="https://buffalonews.com/section/sports/bills/long-form/">Long form</a></li>
	<li id="menu-item-2107474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2107474"><a href="https://buffalonews.com/section/sports/bills/multimedia/">Multimedia</a></li>
</ul>
</li>
<li id="menu-item-1163120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163120"><a href="https://buffalonews.com/section/sports/sabres/">Sabres</a></li>
<li id="menu-item-1163133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163133"><a href="https://buffalonews.com/section/gusto/">Gusto</a>
<ul class="sub-menu">
	<li id="menu-item-1163134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163134"><a href="https://buffalonews.com/section/gusto/food-and-drink/">Food and Drink</a></li>
	<li id="menu-item-1163135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163135"><a href="https://buffalonews.com/section/gusto/music/">Music</a></li>
	<li id="menu-item-1163136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163136"><a href="https://buffalonews.com/section/gusto/festivals/">Festivals</a></li>
	<li id="menu-item-1163138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163138"><a href="https://buffalonews.com/section/gusto/theater/">Theater</a></li>
	<li id="menu-item-1163139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163139"><a href="https://buffalonews.com/section/gusto/family/">Family</a></li>
	<li id="menu-item-1163140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163140"><a href="https://buffalonews.com/section/gusto/movies/">Movies</a></li>
	<li id="menu-item-1163141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163141"><a href="https://buffalonews.com/section/gusto/comedy/">Comedy</a></li>
	<li id="menu-item-1163142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163142"><a href="https://buffalonews.com/section/gusto/art/">Art</a></li>
	<li id="menu-item-1163143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163143"><a href="https://buffalonews.com/section/gusto/dance/">Dance</a></li>
</ul>
</li>
<li id="menu-item-1986017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1986017"><a href="https://buffalonews.com/section/deaths">Deaths</a>
<ul class="sub-menu">
	<li id="menu-item-1163151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163151"><a href="https://buffalonews.com/death-submissions/#">Death Submissions</a></li>
	<li id="menu-item-2373577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2373577"><a href="https://buffalonews.com/death-submissions/helpful-links/">Helpful Links</a></li>
</ul>
</li>
<li id="menu-item-1163153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163153"><a href="https://buffalonews.com/latest/">Last 24 Hours</a></li>
<li id="menu-item-1163154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163154"><a href="http://e-edition.buffalonews.com/">E-edition</a></li>
<li id="menu-item-1163155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163155"><a href="#"><hr></a></li>
<li id="menu-item-1163159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163159"><a href="https://buffalonews.com/section/business/">Business</a>
<ul class="sub-menu">
	<li id="menu-item-2065048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2065048"><a href="https://buffalonews.com/business-wire/">Business Wire</a></li>
</ul>
</li>
<li id="menu-item-1163160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163160"><a href="https://buffalonews.com/section/local-news/crime/">Crime</a></li>
<li id="menu-item-1163161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163161"><a href="https://buffalonews.com/section/opinion/editorials/">Editorials</a></li>
<li id="menu-item-1163162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163162"><a href="https://buffalonews.com/section/education/">Education</a></li>
<li id="menu-item-1163165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163165"><a href="http://thingstodo.buffalonews.com/events/manage/event.php">Submit Event</a></li>
<li id="menu-item-2253060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2253060"><a href="https://buffalonews.com/section/photo-galleries/">Photo Galleries</a></li>
<li id="menu-item-1163167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163167"><a href="https://buffalonews.com/section/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-1163168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163168"><a href="http://www.politifact.com/new-york/">PolitiFact New York</a></li>
</ul>
</li>
<li id="menu-item-1163169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163169"><a href="https://buffalonews.com/section/lifestyles/tv/">TV and Media</a>
<ul class="sub-menu">
	<li id="menu-item-2360890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2360890"><a href="http://e-edition.buffalonews.com/?special=Tops+TV">Tops TV</a></li>
</ul>
</li>
<li id="menu-item-1163174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163174"><a href="https://buffalonews.com/section/weather/">Weather</a></li>
<li id="menu-item-1163179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163179"><a href="https://buffalonews.com/section/lifestyles/weddings/">Weddings</a>
<ul class="sub-menu">
	<li id="menu-item-1163186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163186"><a href="https://forms.buffalonews.com/modules/form_builder/published/WeddingAnnouncementT.php">Submit Announcement</a></li>
	<li id="menu-item-1163187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163187"><a href="https://forms.buffalonews.com/modules/form_builder/published/goldenweddings.php">Submit Golden Anniversary</a></li>
</ul>
</li>
<li id="menu-item-1163189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163189"><a href="https://buffalonews.com/section/history/">WNY History</a></li>
<li id="menu-item-1163190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163190"><a href="#"><hr></a></li>
<li id="menu-item-2291348" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2291348"><a href="https://buffalonews.com/section/sponsored/?post_type=sponsored">Sponsored Content</a></li>
<li id="menu-item-1163196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163196"><a href="https://shopping.buffalonews.com/">[BN] Ads</a></li>
<li id="menu-item-1163198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163198"><a href="http://jobs.buffalonews.com/">Buffalo Job Finder</a></li>
<li id="menu-item-2598992" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2598992"><a href="http://buffalonews.ny.newsmemory.com/?special=Automotive">Sunday Automotive</a></li>
<li id="menu-item-1163199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163199"><a href="http://buffalocars.com/">Buffalo Cars</a></li>
<li id="menu-item-1163200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163200"><a href="http://buffalonews.ny.newsmemory.com/ssindex.php">Special Sections</a></li>
<li id="menu-item-1163202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163202"><a href="https://buffalonews.com/section/gusto/buffalo-magazine/">Buffalo Magazine</a></li>
<li id="menu-item-1163203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163203"><a href="https://buffalo.com/section/buffalo-magazine/wny-weddings/%20">WNY Weddings</a></li>
<li id="menu-item-2055078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2055078"><a href="https://buffalonews.com/section/realestate/">BN Home</a></li>
<li id="menu-item-1163207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1163207"><a href="https://buffalonews.com/classifieds/">Classifieds</a></li>
<li id="menu-item-1163208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1163208"><a href="https://buffalonews.com/corporate/community/contests/">Contests</a></li>
<li id="menu-item-2256640" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2256640"><a target="_blank" href="http://www.gadzoo.com/buffalonews/pets.aspx">Pet Place</a></li>
<li id="menu-item-2360891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2360891"><a href="http://e-edition.buffalonews.com/?special=Tops+TV">Tops TV</a></li>
<li id="menu-item-1163211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1163211"><a href="#"><hr></a></li>
<li id="menu-item-1163212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163212"><a href="https://buffalonews.com/section/local-news/">Communities</a>
<ul class="sub-menu">
	<li id="menu-item-1163213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163213"><a href="https://buffalonews.com/section/local-news/erie-county/">Erie County</a></li>
	<li id="menu-item-1163215" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163215"><a href="https://buffalonews.com/section/local-news/erie-county/amherst/">Amherst</a></li>
	<li id="menu-item-1163216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163216"><a href="https://buffalonews.com/section/local-news/erie-county/buffalo/">Buffalo</a></li>
	<li id="menu-item-1163217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163217"><a href="https://buffalonews.com/section/local-news/erie-county/hamburg/">Hamburg</a></li>
	<li id="menu-item-1163218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163218"><a href="https://buffalonews.com/section/local-news/erie-county/lancaster/">Lancaster</a></li>
	<li id="menu-item-1163219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163219"><a href="https://buffalonews.com/section/local-news/erie-county/town-of-tonawanda/">Town of Tonawanda</a></li>
	<li id="menu-item-1163220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163220"><a href="https://buffalonews.com/section/local-news/niagara-county/">Niagara County</a></li>
</ul>
</li>
<li id="menu-item-1163221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163221"><a href="https://buffalonews.com/section/health-and-fitness/">Health and Fitness</a></li>
<li id="menu-item-1163224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163224"><a href="https://buffalonews.com/section/lifestyles/">Lifestyles</a>
<ul class="sub-menu">
	<li id="menu-item-1300269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1300269"><a href="https://buffalonews.com/section/lifestyles/books/">Books</a></li>
	<li id="menu-item-1163225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163225"><a href="https://buffalonews.com/section/lifestyles/fashion/">Fashion</a></li>
	<li id="menu-item-1163226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163226"><a href="https://buffalonews.com/section/lifestyles/gardening/">Gardening</a></li>
	<li id="menu-item-1163227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163227"><a href="https://buffalonews.com/section/lifestyles/home-and-style/">Home and Style</a></li>
</ul>
</li>
<li id="menu-item-1163229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1163229"><a href="https://buffalonews.com/section/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-1163230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163230"><a href="https://buffalonews.com/section/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-1163231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163231"><a href="https://buffalonews.com/section/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-1163232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163232"><a href="https://buffalonews.com/section/opinion/political-cartoons/">Adam Zyglis</a></li>
</ul>
</li>
<li id="menu-item-1163233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1163233"><a href="https://buffalonews.com/section/state/">State</a></li>
</ul></div>
		</div>

		<div id="nav-search">
			<label for="search-field">
				<svg id="search-icon" xmlns="http://www.w3.org/2000/svg" width="24px" height="24px" viewBox="0 0 24 24" fill="none" stroke="#fff" stroke-width="2" stroke-linecap="round" stroke-linejoin="round">
					<circle cx="10.5" cy="10.5" r="7.5" />
					<line x1="15.8" y1="15.8" x2="21" y2="21" />
				</svg>
			</label>
			<form id="searchform" method="get" name="cse-search-box" role="search" action="/?s">
				<input type="hidden" name="cx" value="006900656957014357757:65jm81-837s">
				<input type="hidden" name="cof" value="FORID:10">
				<input type="hidden" name="ie" value="UTF-8">
				<input type="text" id="search-field" name="s" placeholder="Search">
				<input type="submit" value="Search">
			</form>
			<script src="https://www.google.com/coop/cse/brand?form=searchform&amp;lang=en&cx=006900656957014357757:65jm81-837s"></script>
		</div>

	</div>

	<a href="https://buffalonews.com/" id="custom-logo-link" rel="home" itemprop="url">
		<img id="custom-logo" src="https://buffalonews.com/wp-content/themes/tbn-2016/images/logo-transparent-reverse.png" alt="logo"/>
		
	</a>
	<div id="top-nav-right">

		<input type="checkbox" id="right-menu-input">
		<label for="right-menu-input">
			<i class="fa fa-user fa-2x" aria-hidden="true" id="profile-icon"></i>
			<svg xmlns="http://www.w3.org/2000/svg" class="chevron-down" fill="none" stroke="#fff" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" viewBox="0 0 12 6" height="12" width="12">
				<polyline points="0 0 6 6 12 0"></polyline>
			</svg>
		</label>

		<ul id="right-menu">
						<li class="btn subscribe-button "><a id="nav-sign-in" href="https://login.buffalonews.com/login">Log In</a></li>

			<li class="btn subscribe-button "><a id="nav-subscribe" href="
				https://subscribe.buffalonews.com/?utm_source=sub_btn&utm_medium=button&utm_campaign=sub_nav_btn				">Subscribe Now</a></li>
					</ul>

		<div id="share-menu" class="hidden">

			<ul>
				<li>
					<a href="http://www.facebook.com/sharer.php" onclick="window.open('http://www.facebook.com/sharer.php?u=' + encodeURIComponent(window.location) + '&t=ROGERS%2C%20William%20A.', '_blank'); return false;">
						<i class="fa fa-facebook" aria-hidden="true"></i>
					</a>
				</li>
				<li>
					<a href="https://twitter.com/intent/tweet" onclick="window.open('https://twitter.com/intent/tweet?text=&url=' + encodeURIComponent(window.location), '_blank'); return false;">
						<i class="fa fa-twitter" aria-hidden="true"></i>
					</a>
				</li>
				<li>
					<a href="javascript:;" onclick="window.open('mailto:?subject=ROGERS%2C+William+A.&body=' + encodeURIComponent(window.location)); return false;">
						<i class="fa fa-envelope"></i>
					</a>
				</li>
				<li>
					<label for="social-modal-input">
						<i class="fa fa-share-alt" aria-hidden="true"></i>
					</label>
				</li>
			</ul>

		</div>

	</div>

</nav>

<input type="checkbox" id="social-modal-input">
<div id="social-modal">
	<div id="social-modal-menu">

		<h2>Share this article</h2>

		<main class="main">
			<ul class="list-unstyled share lightbox-share">
				<li class="facebook">
					<a href="http://www.facebook.com/sharer.php" onclick="window.open('http://www.facebook.com/sharer.php?u=' + encodeURIComponent(window.location) + '&t=ROGERS%2C%20William%20A.', '_blank'); return false;">
						<i class="fa fa-facebook" aria-hidden="true"></i> FACEBOOK
					</a>
				</li>
				<li class="twitter">
					<a href="https://twitter.com/intent/tweet" onclick="window.open('https://twitter.com/intent/tweet?text=&url=' + encodeURIComponent(window.location), '_blank'); return false;">
						<i class="fa fa-twitter" aria-hidden="true"></i> TWITTER
					</a>
				</li>
				<li class="email">
					<a href="javascript:;" onclick="window.open('mailto:?subject=ROGERS%2C+William+A.&body=' + encodeURIComponent(window.location)); return false;">
						<i class="fa fa-envelope"></i> EMAIL
					</a>
				</li>
				<li class="pinterest">
					<a data-pin-do="buttonBookmark" data-pin-custom="true" data-pin-log="button_pinit_bookmarklet" data-pin-href="https://www.pinterest.com/pin/create/button/">
					    <i class="fa fa-pinterest fa-2x" aria-hidden="true"></i> Pinterest
					</a>
				</li>
				<li class="linkedin">
					<a href="https://www.linkedin.com/shareArticle" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&amp;url=' + encodeURIComponent(window.location) + '&title=ROGERS%2C%20William%20A.&summary=&source=The Buffalo News', '_blank'); return false;">
						<i class="fa fa-linkedin fa-2x" aria-hidden="true"></i> LinkedIn
					</a>
				</li>
				<li class="reddit">
					<a href="//www.reddit.com/submit" onclick="window.open('//www.reddit.com/submit?url=' + encodeURIComponent(window.location), '_blank'); return false;">
						<i class="fa fa-reddit-alien fa-2x" aria-hidden="true"></i> Reddit
					</a>
				</li>
				<li class="whatsapp">
					<a href="https://api.whatsapp.com/" onclick="window.open('https://api.whatsapp.com/send?text=' + encodeURIComponent(window.location), '_blank'); return false;">
						<i class="fa fa-whatsapp fa-2x" aria-hidden="true"></i> WhatsApp
					</a>
				</li>
			</ul>
		</main>

	</div>
</div>
<img src="https://data.bntech.io/m/3/pixel/1y9WbPk5fHPLhStc2nrD10OT8kK7KWn0" style='position:fixed;left:-1000px;' />

<!--[if lte IE 8]>
	<div id="browser-support-error" class="alert alert-warning">
		<strong>Warning!</strong> Your browser is unsupported. Please upgrade to the latest version of Internet Explorer.
	</div>
	<![endif]-->

<div id='breaking-news' class='jumbotron' style='display: none;'></div>

<!-- begin FB SDK -->
<script>
	window.fbAsyncInit = function() {
		FB.init({
			appId: '1794775337415471',
			xfbml: true,
			version: 'v2.9'
		});
		FB.AppEvents.logPageView();
	};

	(function(d, s, id) {
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) {
			return;
		}
		js = d.createElement(s);
		js.id = id;
		js.src = "//connect.facebook.net/en_US/sdk.js";
		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
</script>
<!-- end FB SDK -->


	<div id="header-ads-container" class="no-print">
		<!-- DFP display ad slot 1x1 - leave the class tbn-2015-1x1 for now. it was previously used to render a 1x1 accordingly on WP vs. Saxotech -->
		<div id="div-gpt-ad-wallpaper" class="tbn-2015-1x1">
			<script>
				googletag.cmd.push(function() {
					googletag.display('div-gpt-ad-wallpaper');
				});
			</script>
		</div>

					<!-- DFP display ad slot leaderboard top at the top of the page -->
			<div id="leaderboard-1">
				<script>
					googletag.cmd.push(function() {
						googletag.display('leaderboard-1');
					});
				</script>
			</div>
			</div>
<div id="container-main" class="container-fluid ">
	<img class="no-show-screen print" src="//bnwordpress.s3.amazonaws.com/The-Buffalo-News.png" alt="print logo" style="width: 300px;">
<div class="container-fluid">
		<div class="row no-print">
		<div class="col-lg-12">
			<div class="search-container">
	<div id="cse-contain" class="row no-gutters round5px">

				<div class="col-md-5 col-sm-12 cse-main container-div" id="cse-searchBox" style="">
						<!--  SEARCH  -->
			<form id="cse-search-box2" name="cse-search-box" class="search" method="get" action="/?s">
			    <input type="hidden" name="cx" value="006900656957014357757:w0ygloomumk" />
			    <input type="hidden" name="cof" value="FORID:10" />
			    <input type="hidden" name="ie" value="UTF-8" />
			    <table width="100%" border="0" cellspacing="0">
				  <tr>
				    <td width="92%" class="search-input round1px"><input autocomplete="off" type="text" size="10" class="gsc-input" name="s" title="search" id="gsc-i-id1" lang="en" dir="ltr" spellcheck="false" placeholder="Search Obits and Notices" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search Obits and Notices'"></td>
				    <td class="search-button round1px"><input type="image" value="Search" name="sa" src="https://www.google.com/uds/css/v2/search_box_icon.png" class="gsc-search-button gsc-search-button-v2" title="search"></td>
				  </tr>
				  <!--
				  <tr>
				  	<td colspan="2"><small>Use symbols or specific words in your search to make your results more exact. <a target="_blank" href="https://support.google.com/websearch/answer/2466433?hl=en">Learn More <i class="fa fa-angle-double-right" aria-hidden="true"></i></a></small></td>
				  </tr> -->
				</table>
			</form>
			<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box2&amp;lang=en&cx=006900656957014357757:w0ygloomumk"></script>
		</div>

					<div class="col-md-7 col-sm-12" id="search-terms">
				<div class="row search-term-list">						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item strong">
							<a href="http://buffalonews.com/section/deaths/" onClick="">Deaths Home</a>
						</div>						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item ">
							<a href="http://buffalonews.com/section/deaths/death-notices/" onClick="">Death Notices</a>
						</div>						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item ">
							<a href="http://buffalonews.com/section/deaths/obituaries/" onClick="">Obituaries</a>
						</div>						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item strong">
							<a href="http://buffalonews.com/death-submissions/" onClick="">Submissions</a>
						</div>						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item ">
							<a href="http://buffalonews.com/section/deaths/memoriam/" onClick="">In Memoriam</a>
						</div>						<div class="col-lg-4 col-md-4 col-sm-2 col-xs-4 list-item ">
							<a href="http://buffalonews.com/section/deaths/celebration-of-life/" onClick="">Celebration of Life</a>
						</div>				</div>
			</div>	</div>
</div>
	<script type="text/javascript">
		bindInOut(jQuery('#gsc-i-id1'),'Search Obits and Notices');
	</script>
<script type="text/javascript">
jQuery(document).ready(function() {
	jQuery('[data-toggle="tooltip"]').tooltip();
});
</script>
		</div>
	</div>
		<div class="row">
		<div class="main obits-main col-lg-9"><noscript>
	<style>
		/* show transient articleData column now if JS is not available */
		.transient { display: table-cell; }
	</style>
</noscript>
<article class="article-body">
	<div class="breadPrevNext no-print">
		<p id="category-header"><a href="https://www.buffalonews.com/obits">Deaths</a>&nbsp;&nbsp;<i class='fa fa-angle-right'></i>&nbsp;&nbsp;Death Notices</p>
	</div>
		<div class="article-data article-data-transient">
		<ul>
			<li class="updated print">
				<p>					Published  <span class="timestamp post-date"  itemprop="datePublished" data-time="1548565200" data-time-type="article-pub">Sun, Jan 27, 2019</span>
				</p>
			</li>
		</ul>
		<div class="socmed-util no-print">
			<ul>
				<li class="facebook">
					<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fbuffalonews.com%2F2019%2F01%2F27%2Frogers-william-a%2F&amp;t=ROGERS%2C%20William%20A." target="_blank">
					<i class="fa fa-facebook"></i><span>SHARE</span>
					</a>
				</li>
				<li class="twitter">
					<a href="https://twitter.com/intent/tweet?text=ROGERS, William A.&url=https%3A%2F%2Fbuffalonews.com%2F2019%2F01%2F27%2Frogers-william-a%2F" target="_blank">
					<i class="fa fa-twitter"></i><span>TWEET</span>
					</a>
				</li>
				<li class="mail">
					<a href="mailto:?subject=ROGERS, William A.&body=https://buffalonews.com/2019/01/27/rogers-william-a/">
					<i class="fa fa-envelope"></i><span>EMAIL</span>
					</a>
				</li>
			</ul>
		</div>
	</div><!-- end .article-data -->

	<div class="article-content-container">
		<div class="article-content" style="padding-right:0px">
			<div class="the-content" itemscope itemtype="http://schema.org/Person">
								<div class="article-title">
					<h2 itemprop="name">ROGERS, William A.</h2>
				</div>
				<div itemprop="description">
					<p>ROGERS - William A. January 15, 2019. Survived by loving family and friends. A Funeral Service will be held on Wednesday, February 6, 2019, at 11:30 AM at THE DIETRICH FUNERAL HOME, INC., 2480 Kensington Ave., Amherst. Online condolences may be shared at www.TheDietrichFuneralHome.com</p>
<div class="funeral-home"><h2>Funeral Home: </h2><p class="funeral-home"><a href="http://www.TheDietrichFuneralHome.com" target="_blank">Dietrich Funeral Home, Inc. <i class="fa fa-angle-right"></i></a></p></div>				</div>
			</div><!-- /.the-content -->

				<div id="comment-container">
					<h2>Guest Book</h2>
<small class="small">Powered by Facebook</small>
<div class="fb-comments commenting deaths-comments memoriams-comments" data-href="https://buffalonews.com/2019/01/27/rogers-william-a/" data-num-posts="2" mobile="true"></div>				</div>

		</div>
	</div>
	<!-- end .article-content-container -->
</article>
<script src="https://buffalonews.com/wp-content/themes/tbn-2016/js/jquery.responsive-dom.min.js"></script><!-- tried to load as wp_register_script but it breaks the script -->
<script type="text/javascript">
	(function() {
		var jQuerytransient = jQuery('.article-data-transient');
	
		// move transient paragraph to the right column when viewport width < 602px
		jQuerytransient.responsiveDom({
			appendTo: '.the-content',
			mediaQuery: 'screen and (max-width: 601px)',
			callback: function(mediaMatched) {
				// This callback is called when the dom is updated
				if (mediaMatched) {
					console.log('articleData column moved below the-content');
				} else {
					console.log('articleData column moved back to the left column next to .the-content');
				}
			}
		});
		// let css know the js is done
		jQuerytransient.addClass('js-complete'); 
	})();
</script>
<script type="text/javascript">
	jQuery('body').addClass('obits obits30016');
</script>		</div>
		<div class="col-md-3 obits-right-rail no-print">
			<div class="col-md-12 col-sm-6">
				<div id="bnAdBlock-boxmedium-1">
					<script>
						googletag.cmd.push(function() { googletag.display('bnAdBlock-boxmedium-1'); });
					</script>
				</div>
			</div>
			<div class="col-md-12 col-sm-6">
				<div id="bnAdBlock-boxmedium-2">
					<script>
						googletag.cmd.push(function() { googletag.display('bnAdBlock-boxmedium-2'); });
					</script>
				</div>
			</div>
			<div class="col-md-12 col-sm-6">
				<div id="bnAdBlock-boxmedium-3">
					<script>
						googletag.cmd.push(function() { googletag.display('bnAdBlock-boxmedium-3'); });
					</script>
				</div>
			</div>
		</div>
	</div>
</div>		</div> <!-- /#container-main -->

				<div class="no-print">
			<div id="leaderboard-2">
				<script type="text/javascript">
					googletag.cmd.push(function() { googletag.display('leaderboard-2'); });
				</script>
			</div>
		</div>
		
		<script type="text/javascript">
		try { _402_Show(); } catch(e) {}
		</script>

		<footer class="no-print">
			<div class="container-fluid">
				<div class='row'>
					<div class="col-sm-6 col-md-3">
						<div class="quick_links">
							<h3><span class="icon"><i class="fa fa-newspaper-o"></i></span>Quick Links</h3>
							<div class="menu-footer-quick-links-container"><ul id="menu-footer-quick-links" class="multiColumn2"><li id="menu-item-2378005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2378005"><a href="https://buffalonews.com/corporate/contact-us/">Contact Us</a></li>
<li id="menu-item-2378007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2378007"><a href="https://buffalonews.com/corporate/general-help/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-2378008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2378008"><a href="https://buffalonews.com/sitemap/">Sitemap</a></li>
<li id="menu-item-2378009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2378009"><a href="https://buffalonews.com/corporate/subscribe/faqs/">FAQs</a></li>
<li id="menu-item-2378011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2378011"><a href="https://buffalonews.com/corporate/community/contests/">Contests</a></li>
<li id="menu-item-2378012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2378012"><a href="https://services.buffalonews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html">Manage Subscription</a></li>
<li id="menu-item-2378014" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2378014"><a href="https://buffalonews.com/corporate/advertise/advertise-print/">Advertise With Us</a></li>
<li id="menu-item-2378386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2378386"><a href="https://buffalonews.com/deliver-us">Deliver Us</a></li>
</ul></div>						</div>
						<div class="follow-us">
							<ul class="socmed">
																<li class="facebook"><a href="https://www.facebook.com/TheBuffaloNews"><i class="fa fa-facebook"></i></a></li>								<li class="twitter"><a href="https://twitter.com/thebuffalonews"><i class="fa fa-twitter"></i></a></li>								<li class="youtube"><a href="https://www.youtube.com/user/BuffaloNewsVideo"><i class="fa fa-youtube"></i></a></li>								<li class="google"><a href="https://plus.google.com/+buffalonews/posts"><i class="fa fa-google"></i></a></li>							</ul>
						</div>
					</div>
					<div class="col-sm-6 col-md-4">
						<div class="newsletters">							<h3><span class="icon"><i class="fa fa-envelope"></i></span>Newsletters</h3>
							<form id="emailSignupFormFooter" method="post">
								<ul class="multiColumn2">										<li>
											<label class="newsletter-item" for="nlabel-[BN] Blitz">
												<input type="checkbox" id="nlabel-[BN] Blitz" name="[BN] Blitz" value="253060" checked="checked">
												[BN] Blitz											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-Good Morning, Buffalo">
												<input type="checkbox" id="nlabel-Good Morning, Buffalo" name="Good Morning, Buffalo" value="253062" checked="checked">
												Good Morning, Buffalo											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-Things to do in WNY">
												<input type="checkbox" id="nlabel-Things to do in WNY" name="Things to do in WNY" value="253064" checked="checked">
												Things to do in WNY											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-Death Notices">
												<input type="checkbox" id="nlabel-Death Notices" name="Death Notices" value="253066" checked="checked">
												Death Notices											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-[BN] Hockey">
												<input type="checkbox" id="nlabel-[BN] Hockey" name="[BN] Hockey" value="253061" checked="checked">
												[BN] Hockey											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-Food and Drink">
												<input type="checkbox" id="nlabel-Food and Drink" name="Food and Drink" value="281216" checked="checked">
												Food and Drink											</label>
										</li>										<li>
											<label class="newsletter-item" for="nlabel-Buffalo School Board Election">
												<input type="checkbox" id="nlabel-Buffalo School Board Election" name="Buffalo School Board Election" value="287450" checked="checked">
												Buffalo School Board Election											</label>
										</li>								</ul>
								<div class="signup">
									<div class="input-group">
										<input type="email" class="form-control" id="email" name="txtEmailAddressFooter" placeholder="Your Email Address">
										<span class="input-group-btn">
											<button type="submit" class="btn btn-danger" type="button">Sign Up</button>
										</span>
									</div><!-- /input-group -->
								</div><!-- /.signup -->
							</form>
						</div>
					</div>
					<div class="col-sm-6 col-md-5">
						<div class="websites">
							<h3><span class="icon"><i class="fa fa-globe"></i></span>Our Websites</h3>
								<div class="menu-footer-our-sites-container"><ul id="menu-footer-our-sites" class="multiColumn3"><li id="menu-item-2377980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377980"><a href="https://jobs.buffalonews.com/">Buffalo Job Finder</a></li>
<li id="menu-item-2377982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377982"><a href="http://buffalocars.com/">Buffalo Cars</a></li>
<li id="menu-item-2377984" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377984"><a href="https://shopping.buffalonews.com/">[BN] Ads</a></li>
<li id="menu-item-2377985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377985"><a href="http://e-edition.buffalonews.com/ssindex.php">Special Sections</a></li>
<li id="menu-item-2377986" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377986"><a href="https://www.buffalo.com">Buffalo Magazine</a></li>
<li id="menu-item-2377988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377988"><a href="https://buffalo.com/section/buffalo-magazine/wny-weddings/">WNY Weddings</a></li>
<li id="menu-item-2377989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377989"><a href="https://buffalonews.com/section/realestate/">[BN] Home</a></li>
<li id="menu-item-2377995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2377995"><a href="https://buffalonews.com/classifieds">Classifieds</a></li>
</ul></div>							<hr>
							<span itemscope itemprop='publisher' itemtype="http://schema.org/Organization">
								&copy; 1999 - 2019 - <span itemprop='name'>The Buffalo News</span> copyright-protected material
							</span>
						</div>
					</div>
				</div>
			</div>
		</footer>

		<link rel='stylesheet' id='cse-css'  href='https://buffalonews.com/wp-content/themes/tbn-2016/google/cse/css/cse.css?ver=5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/vendor/fontsmoothie.min.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/pym.v1.min.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/search.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/plugins/content-management/controllers/breaking-news.js.php'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bn_share_menu.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bn_custom_share_icon.js?ver=5.1'></script>
<script type='text/javascript' src='https://cdn.polyfill.io/v3/polyfill.min.js?features=forEach%2CIntersectionObserver%2CIntersectionObserverEntry&#038;flags=gated&#038;ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/menu.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bn_lazy_load.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bn_navbar.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-content/themes/tbn-2016/js/bn_gallery/bn_gallery.js?ver=5.1'></script>
<script type='text/javascript' src='https://buffalonews.com/wp-includes/js/wp-embed.min.js?ver=5.1'></script>

		<script type="text/javascript">
			//Newsletter footer signup form
			jQuery(document).ready(function () {
			jQuery("#emailSignupFormFooter").submit(function(e) {

				var selectedValues = [];
				jQuery('#emailSignupFormFooter .newsletter-item input:checked').each(function(i, input) {
				 var value = jQuery(input).val().trim();
				if(value != "all"){
					selectedValues.push(value);
				}
				});
				selectedValues = selectedValues.join(',');
				var email = jQuery('footer .newsletters input[name=txtEmailAddressFooter]').val();
				var data = "txtAudienceGUID=" + selectedValues + "&txtEmailAddress=" + email;


				jQuery.ajax({
				crossDomain:true,
				data:data,
				type: "POST",
				cache: false,
				url: "//newsletters.buffalonews.com/templates/addToAudience.php",
				error: function(xhr, status, error) {
						window.location.replace("//buffalonews.com/newsletter/?message=" + error);
				},
				success: function (msg){
					if (msg == '<p>Fail: Invalid Email Address.</p>') {
						window.location.replace("//buffalonews.com/newsletter/?message=Please enter a valid email address.");
					} else if (msg == '<p>Fail: Invalid AudienceGUID.</p>'){
						window.location.replace("//buffalonews.com/newsletter/?message=Please check the newsletters you'd like.");
					} else {
						window.location.replace("//buffalonews.com/newsletter/?success");
					}
				}
				});

				e.preventDefault();
				return false;
				 });
			});
		</script>

		<!-- Doubleclick Code for Retargeting tag -->
		<!-- Retargeting tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup -->
		<script type="text/javascript">
		/* <![CDATA[ */
		var google_conversion_id = 993747714;
		var google_conversion_label = "_REmCLbFzAMQgsbt2QM";
		var google_custom_params = window.google_tag_params;
		var google_remarketing_only = true;
		/* ]]> */
		</script>
		<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"></script>


		<!--Adblock Check-->
		<script type="text/javascript">

			if( window.canRunAds === undefined ){
	//			console.log("ad block is running ");
			}
		// adblocker detected, show fallback
			jQuery(document).ready(checkAds1());

			function checkAds1() {
				if(( window.canRunAds === undefined )||!(window.googletag && googletag.pubadsReady))
				{
					//console.log("ad block is running ");
					ga('send', 'event', 'Adblock', 'Blocked', 'Adblock is on.',1, {'nonInteraction': 1});
					if (typeof showABModal === "function") {
						showABModal();
					}
				}
				else
				{
					//console.log("ad block is not operating ");
					ga('send', 'event', 'Adblock', 'Unblocked', 'Adblock is off.',1, {'nonInteraction': 1});
				}
			}

		</script>
		<!-- End Adblock Check -->

		<noscript>
			<div style="display:inline;">
				<img height="1" width="1" style="border-style:none; position: absolute; top: 0;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/993747714/?value=0&amp;label=_REmCLbFzAMQgsbt2QM&amp;guid=ON&amp;script=0"/>
			</div>
		</noscript>

	</body>
</html>
